Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Gentoo 2007.0 released
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Announcements
View previous topic :: View next topic  
Author Message
davecs
LXF regular


Joined: Sun Apr 10, 2005 12:13 am
Posts: 530
Location: Dagenham, Essex

PostPosted: Tue May 15, 2007 12:25 am    Post subject: Reply with quote

Back in the days when I used to use Gentoo, there was absolutely no speed advantage using OpenOffice-bin vs OpenOffice-source. Well except for the installation itself of course. OOo seemed to react more to the efficiency of the environment it was running in, than how it had been compiled.
_________________

Asus Asus M2N32 WS Pro+Athlon AM2/4200+ — GeForce 7600GT — 2Gb Cosair VS RAM — 500Gb WD5000AAKS SATA Drive — PCLinuxOS
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8365
Location: Warrington, UK

PostPosted: Tue May 15, 2007 12:36 am    Post subject: Reply with quote

There is a saving in startup time, but the most noticeable difference is the appearance. openoffice on my laptop looks so much better than openoffice-bin on my desktop. One fits in with the KDE desktop and the other looks about as at home as a nun in a brothel Sad
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
Carl_Hesketh



Joined: Thu Jun 29, 2006 11:38 am
Posts: 85

PostPosted: Tue May 15, 2007 3:57 pm    Post subject: Reply with quote

I had a go with Gentoo the last time it was on the LXF cover disc, and despite following the
"idiots guide" to the letter, I couldn't get it to install. It kept falling over and complaining about some missing dependency for some hardware. I have forgotten what, but Googling the error message didn't produce anything helpful.

I might have another go with it someday, but I don't have room.... I've already got Ubuntu 6.06 (64 bit), Ubuntu 7.04, Debian Etch, and OpenBSD 4.0 on the go.
Back to top
View user's profile Send private message
spottedcat
LXF regular


Joined: Mon Oct 31, 2005 3:14 pm
Posts: 971
Location: UK

PostPosted: Tue May 15, 2007 5:58 pm    Post subject: Reply with quote

nelz wrote:
... about as at home as a nun in a brothel


I'll let you into a secret, nelz. That wasn't a nun. She was just dressed up like one. Razz
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8365
Location: Warrington, UK

PostPosted: Tue May 15, 2007 7:37 pm    Post subject: Reply with quote

I don't know, I wasn't there, so I'll have to take your word for it Wink
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
shifty_ben
LXF regular


Joined: Tue Oct 04, 2005 10:56 am
Posts: 1292
Location: Ipswich

PostPosted: Tue May 15, 2007 9:05 pm    Post subject: Reply with quote

Anyone else getting this;

Quote:
Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r6'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'


When they try to emerge a package?
_________________
Need a New Signature
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
spottedcat
LXF regular


Joined: Mon Oct 31, 2005 3:14 pm
Posts: 971
Location: UK

PostPosted: Tue May 15, 2007 10:53 pm    Post subject: Reply with quote

shifty_ben wrote:
Anyone else getting this;

Quote:
Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r6'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'


When they try to emerge a package?


Earlier in the thread, shifty_ben wrote:
but I am just going to be changing my profile (though i have been meaning to update it since portage started warning me about it.)


When did you last do an emerge --sync and emerge -Du world? Wink

My box:

Quote:
# emerge --search xorg-x11
Searching...
[ Results for search key : xorg-x11 ]
[ Applications found : 1 ]

* x11-base/xorg-x11
Latest version available: 7.2
Latest version installed: 7.2
Size of files: 0 kB
Homepage: http://xorg.freedesktop.org
Description: An X11 implementation maintained by the X.Org Foundation (meta package)
License: as-is


I think you might find this bugzilla page interesting.

By the way, I've been playing with the 2007.0 live CD and I can't get it to zap my partitions without warning me first. I got a basic install with a minimal gnome desktop up and running fairly easily. I'll post more details tomorrow when I'm more awake.
Back to top
View user's profile Send private message
shifty_ben
LXF regular


Joined: Tue Oct 04, 2005 10:56 am
Posts: 1292
Location: Ipswich

PostPosted: Tue May 15, 2007 11:03 pm    Post subject: Reply with quote

Quote:
By the way, I've been playing with the 2007.0 live CD and I can't get it to zap my partitions without warning me first


Easy way try to do it without Wink

Haven't run a full update in a while, I have quite a nice stable system at the moment, and work being quite busy means I don't have a lot of time to fix anything that breaks during an upgrade.
_________________
Need a New Signature
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
spottedcat
LXF regular


Joined: Mon Oct 31, 2005 3:14 pm
Posts: 971
Location: UK

PostPosted: Tue May 15, 2007 11:06 pm    Post subject: Reply with quote

shifty_ben wrote:
Quote:
By the way, I've been playing with the 2007.0 live CD and I can't get it to zap my partitions without warning me first


Easy way try to do it without Wink


You misunderstand me. Laughing That was a reference to the complaints on Gentoo forums that it's wiped out partitions without warning. But it played nicely for me.
Back to top
View user's profile Send private message
shifty_ben
LXF regular


Joined: Tue Oct 04, 2005 10:56 am
Posts: 1292
Location: Ipswich

PostPosted: Tue May 15, 2007 11:12 pm    Post subject: Reply with quote

Its funny, I have always found USE flags to be quite helpful, except for today why I was trying to work out why my upgrade of MySQL wasn't working as expected. After much cursing I found that I had the minimal use flag activated for some unknown reason. Result = Client only.

I don't need a Live CD with a fancy installer to wipe my partitions without warning, i did it quite happily with the manual, and the 2006.0 build. Perhaps that's just me!
_________________
Need a New Signature
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
nordle
LXF regular


Joined: Fri Apr 08, 2005 10:56 pm
Posts: 1500

PostPosted: Wed May 16, 2007 12:10 am    Post subject: Reply with quote

nelz wrote:
The best way to install Gentoo is using the handbook, then you really understand what you've got and how it works - in a way that Slackware users can only dream about Wink


Sir, I shall not rise to your baiting...... well maybe just a little.

I run Slackware, but not as we know it. It's about 320MB Slackware pacakges. Then 170MB custom QT, KDE_Libs, KDE_Utils, OpenOffice.org 2.2.0 and XFCE (yep, after 7 years I dumped KDE about 8 weeks ago, in homage to Gnome for a month).
--without-arts is an amazing switch. I recompiled KDE_Libs using it, and ANY QT app that I have installed ie Amarok, K3b, Kaffeine etc. Nothing crashes, at all. Using XFCE and --without-arts seems to have removed totally the once every few weeks crash I might expect from KDE/QT app. Arts was not their finest hour.

Gentoo would appeal, I can set these flags permanently, but managed it fine in Slackware anyway.

I did install gentoo using the online docs, chrooting and all that gubbins. It was on an Athlon64-3200 with 1GB RAM, but took about 4 hours to get a basic login.

I seem to remember trying to stick to a stage 3 install, then running something like emerge update world or something like that. Then every app after that required to download and compile, so I put it to one side.

A bit OT, but I'm luving XFCE, Geany, Claws-Mail (what was sylpheed-claws), GQView, Transmission, ePDFViewer, Htop, gxine, mplayer, OOo (cant do without Amarok, Kaffeine and K3b though).

I do miss konqueror's all round abilities, tabbed browsing, great Service Menus, great integration etc. But I'm liking Thunar, you can REALLY easily add your own Service Menus, much easier than konq. BUT it doesnt do tabbed browsing, and simple highlighting of dirs to get disk usage is not possible, so occasionally I dip into Krusader, but again, its just a thunar service menu added now.

All these apps give great speed, do what I need. Its a little weird though. I've got the fastest PC I've ever owned, when I put it together it was position 1,500 something on 3dMark leader board. Yet I'm using apps that would run on my P2!
(yeah, but my P2 can't encode h264 @ 80fps!)
I guess it leaves cpu cycles to be spent on what there supposed to.

/endith the OT
_________________
I think, therefore I compile
Back to top
View user's profile Send private message
Marrea
LXF regular


Joined: Fri Apr 08, 2005 10:32 pm
Posts: 1868
Location: Chilterns, West Hertfordshire

PostPosted: Sun May 20, 2007 8:59 pm    Post subject: Reply with quote

spottedcat wrote:
But shifty-ben's right, Marrea. Gentoo's not that bad. Go on. You know you want to. Very Happy


When I listen to you lot going on about your Gentoo installs, you might as well be talking in a foreign language. Razz

Maybe one of these days I'll get around to giving it a go. Smile
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8365
Location: Warrington, UK

PostPosted: Mon May 21, 2007 3:04 pm    Post subject: Reply with quote

nelz wrote:
Unfortunately, there don't seem to be many GRP packages yet, although there are some on the DVD.


My mistake, the DVD will install a full KDE desktop from binary packages in a comparable time to other distros.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
spottedcat
LXF regular


Joined: Mon Oct 31, 2005 3:14 pm
Posts: 971
Location: UK

PostPosted: Thu May 24, 2007 12:50 pm    Post subject: Reply with quote

On 15th May, I wrote:
By the way, I've been playing with the 2007.0 live CD and I can't get it to zap my partitions without warning me first. I got a basic install with a minimal gnome desktop up and running fairly easily. I'll post more details tomorrow when I'm more awake.


It's taken me some time to wake up. Rolling Eyes Yawn.... Anyway, not much more to add really. Except...if you're needing to set up partitions, the choice is between fdisk in a terminal and a pretty crummy graphical installer that only lets you create primary partitions. If you want to use a graphical partitioner, my advice would be to set up the HD with a live disc such as Gparted, Mepis or Ubuntu before booting up the Gentoo live CD.

However..... A thoughtful and thought-provoking comment from a poster on the Gentoo thread I linked to.

Quote:
Gentoo is a source based meta-distribution. It is impossible to gain any feel for how it works if the source-based part or the meta-distribution part are avoided. In fact, the problem with the installer is that it leads to very false impressions about what using, administering, maintaining, and updating a Gentoo installation is like. If the installation process is too long for your tastes (and it takes me about 7 hours to get a full stage 3 manual installation up and running, not weeks), then it's unlikely that Gentoo is for you.

.....

Actually the installer, as it said in the 2006.1 version (I have not checked the latest one yet), was intended for use in simplifying the process of multiple installations when the admin already understands the manual installation process thoroughly. It has stated that it is not intended to replace the manual installation method which remains the recommended method for installing Gentoo.

These forums have been almost unanimous in urging particularly new users not to use the installer in favor of the manual method because the installer is designed to obscure many of the things that are critical to properly administering and using a Gentoo system.


A matter for debate but he has a point there. I did get Gentoo up and running with the 2006.1 Gtk installer, but it was one helluva steep learning curve to discover what "using, administering, maintaining, and updating a Gentoo installation is like" afterwards.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8365
Location: Warrington, UK

PostPosted: Thu May 24, 2007 1:14 pm    Post subject: Reply with quote

I still think that a manual install is best for first time users, it gives you much more of an understanding of the system. The GTK and curses installers are great time savers for those that already know the system.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Announcements All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast