External USB HDD

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

External USB HDD

Postby youlikeicecream » Fri Jun 03, 2005 11:58 am

HI, I am having a small problem. I am using a USB2 160GB LACIE External HDD, formatted as a primary FAT32 partition ... Whenever the Disk is connected, an Unmounted icon is placed on the desktop ... I can click on it and it mounts just fine. Unfortunately I cannot write to it. Checked the permissions and I should be able to write to it but it still denies me write access. Ideally I would like to just put the entry for this disk into my /etc/fstab file. And I have done so with a command as such :

/dev/sdb1 /mnt/LACIE vfat 0 0 (I think thats what I put) I have even tried it with fmask=775,dmask=775

but it still wont let me write. Also when I have mounted sdb1 to /mnt/LACIE the automated USB icon gets confused because it wants to mount the device sdb1 to /media/sdb1.

I am using Kubuntu (latest) with KDE 3.4

any help would be most appreciated

Mike Smith :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby youlikeicecream » Fri Jun 03, 2005 3:01 pm

Can anyone help ?
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby towy71 » Fri Jun 03, 2005 3:42 pm

my advice would be to let udev create the icon and then as root in a terminal type: umount /media/sdb1
then type mount -rw /media/sdb1
not pretty but I think it would work
ymmv
Dick
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4263
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

RE: External USB HDD

Postby youlikeicecream » Fri Jun 03, 2005 5:28 pm

thanks for the advice, but that would leave my user unable to write to the drive I would have thought? What I really wanted was for the drive to be mounted at boot as udev doesn't mount it at boot, you actually have to click on the icon to mount it. I wanted to store icons and piccies on the USB disk, and so it would be nice for it to mount at boot so that my icons and backgrounds are available when i log in.

Mike :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby towy71 » Fri Jun 03, 2005 10:53 pm

doh! There was I shooting my mouth off again, the /etc/fstab section should read:

/dev/hda1 /mnt/lacie vfat defaults 0 0

HTH
Dick
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4263
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

RE: External USB HDD

Postby skecs » Sat Jun 04, 2005 7:27 am

towy71 -
"doh! There was I shooting my mouth off again, the /etc/fstab section should read:

/dev/hda1 /mnt/lacie vfat defaults 0 0"

Don't you mean:

/dev/sda1 /mnt/lacie vfat defaults 0 0 :?
Regards from
Downunder!
.... _
... (0)>
... / /\
.. / / .)
.. V_/_
Linux Powered!
User avatar
skecs
 
Posts: 76
Joined: Fri Apr 22, 2005 9:22 am
Location: Bathurst, NSW Australia

RE: External USB HDD

Postby towy71 » Sat Jun 04, 2005 7:30 am

double doh ;)
nice sig skecs
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4263
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

RE: External USB HDD

Postby skecs » Sat Jun 04, 2005 7:56 am

Ta - it's how I learnt to draw on computers!

There is a whole site of ASCII penguins at ASCII-Pinguine:

http://www.informatik.uni-freiburg.de/~ ... nguin.html
Regards from
Downunder!
.... _
... (0)>
... / /\
.. / / .)
.. V_/_
Linux Powered!
User avatar
skecs
 
Posts: 76
Joined: Fri Apr 22, 2005 9:22 am
Location: Bathurst, NSW Australia

RE: External USB HDD

Postby wyliecoyoteuk » Sat Jun 04, 2005 8:33 am

The best solution would be to write a script for udevd.

this link might help.

http://www.linuxformat.co.uk/index.php? ... topic&t=61
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3454
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

RE: External USB HDD

Postby youlikeicecream » Sat Jun 04, 2005 9:12 am

/dev/sda1 /mnt/lacie vfat defaults 0 0

is what I have tried before, i will see if that works this time and then if not will try ther udev thing

thanks
mike :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby youlikeicecream » Sat Jun 04, 2005 9:21 am

ok, i tried that ... didn't mount at boot and as root i tried this ...

root@Kubuntu:/home/mike # mount /mnt/LACIE
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby youlikeicecream » Sat Jun 04, 2005 9:23 am

PS . it is sdb1, my ntfs SATA disk is sda1

mike :)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby youlikeicecream » Sat Jun 04, 2005 9:27 am

root@Kubuntu:/home/mike # mount -t vfat -rw /dev/sdb1 /mnt/LACIE
>>couldnt write to it as root.

root@Kubuntu:/home/mike # chmod 775 /mnt/LACIE
>>still couldnt write

am confused
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

RE: External USB HDD

Postby Nigel » Sat Jun 04, 2005 9:36 am

shouldn't that be

mount -t vfat -o rw /dev/sdb1 /mnt/LACIE

???
at least, that's what is implied by the man page for mount under SuSE 9.2
Hope this helps,

Nigel.
User avatar
Nigel
LXF regular
 
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

RE: External USB HDD

Postby youlikeicecream » Sat Jun 04, 2005 9:41 am

yeah, thats it. But it allows only root to write to it. what do i need to do to get access for my user (also part of the 'root' group)
youlikeicecream
LXF regular
 
Posts: 721
Joined: Fri Jun 03, 2005 11:40 am
Location: Oxford

Next

Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests

cron