libtool.m4 and ltmain.sh have a version mismatch! Kdevelop

Code junkies hangout here

Moderators: ChrisThornett, LXF moderators

libtool.m4 and ltmain.sh have a version mismatch! Kdevelop

Postby GMorgan » Mon May 01, 2006 9:36 pm

I've just tried compiling an old project on Kdevelop in Gentoo. The problem I'm getting is a complaint along the following lines

Code: Select all
checking for correct ltmain.sh version... no
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.22, ltmain.sh = 1.5a) ***

Please run:

libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.

*** Exited with status: 1 ***


I've emerged libtool which is probably causing the problem butI haven't a clue what to do about ltmain.sh. As far as I can tell there is no ebuild that refers to it (certainly nothing at gentoo.org. Anyone know how to solve this.

I'm also getting a few warnings
Code: Select all
/usr/share/aclocal/pth.m4:43: warning: underquoted definition of _AC_PTH_ERROR
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
/usr/share/aclocal/pth.m4:55: warning: underquoted definition of _AC_PTH_VERBOSE
/usr/share/aclocal/pth.m4:61: warning: underquoted definition of AC_CHECK_PTH
/usr/share/aclocal/pilot-link.m4:1: warning: underquoted definition of AC_PILOT_LINK_HOOK
/usr/share/aclocal/ao.m4:9: warning: underquoted definition of XIPH_PATH_AO
autoheader


I don't think these are a problem but I thought I'd post them in case they turn out to be important.
GMorgan
LXF regular
 
Posts: 684
Joined: Thu Jan 12, 2006 6:58 pm
Location: South Wales, UK

RE: libtool.m4 and ltmain.sh have a version mismatch! Kdevel

Postby bluemonki » Tue May 02, 2006 9:18 am

So what happens if you run:
Code: Select all
libtoolize --copy --force

like it asks you to?
---------------------------------

A wizard has turned you in to a whale. Is this awesome? (Y/N)

Image
User avatar
bluemonki
 
Posts: 11
Joined: Sat Oct 29, 2005 8:18 pm
Location: uk

RE: libtool.m4 and ltmain.sh have a version mismatch! Kdevel

Postby GMorgan » Tue May 02, 2006 9:54 pm

It doesn't give any output. It may have done nothing, or it may have installed rootkits throughout my machine, the complete lack of output leaves me in the dark.
GMorgan
LXF regular
 
Posts: 684
Joined: Thu Jan 12, 2006 6:58 pm
Location: South Wales, UK

RE: libtool.m4 and ltmain.sh have a version mismatch! Kdevel

Postby bluemonki » Wed May 03, 2006 12:11 pm

Ok lets stop taking the paranoia pills for a sec and check it out:

http://www.delorie.com/gnu/docs/libtool/libtool_29.html

...right so no rootkits there.

So once you've run the command do you still get the same error?

If you do check this out:
http://66.249.93.104/search?q=cache:NhcODh1KiV4J:www.gentoo.org/news/en/gwn/20041220-newsletter.xml%3Fstyle%3Dprintable+libtool.m4+and+ltmain.sh+have+a+version+mismatch!&hl=en&gl=uk&ct=clnk&cd=1&client=firefox-a
---------------------------------

A wizard has turned you in to a whale. Is this awesome? (Y/N)

Image
User avatar
bluemonki
 
Posts: 11
Joined: Sat Oct 29, 2005 8:18 pm
Location: uk

RE: libtool.m4 and ltmain.sh have a version mismatch! Kdevel

Postby GMorgan » Wed May 03, 2006 10:59 pm

I didn't seriously think there were rootkits I'm just saying for all I know there maybe :wink: .

Thanks for the link. Its a known bug then at least I will be able to get it running.
GMorgan
LXF regular
 
Posts: 684
Joined: Thu Jan 12, 2006 6:58 pm
Location: South Wales, UK


Return to Programming

Who is online

Users browsing this forum: No registered users and 2 guests

cron