More printer misery Epson/Ubuntu

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

More printer misery Epson/Ubuntu

Postby catgate » Thu May 22, 2014 3:47 pm

I am in the mire again on the printing front.
The last printer to feature was an Epson WF-2510, which was obtained to replace an Epson WF-315, which I failed to install.
Thanks to assistance from Linux Format stalwarts I installed the WF-2510 and it ran nicely from the beginning of March until about a week ago. when it suddenly decided to throw in the towel and refused to allow me to renew the last “running in cartridge”. This resulted in another trip to the Goole chandler and yet another new printer.
In view of the information in Towi71's link “https://www.openprinting.org/printer/Epson/Epson-XP-312_313_315_Series” I decided to retry a new WF-315, which is similar to the WF-2510 (but with fewer bells and whistles).
Since getting it home last Saturday a.m. I have failed to get it to work properly. It will work as a copier and I have had it run Simple Scan, but so far I have failed most miserably to get it to print.
I have tried those “deb” files that seemed appropriate to my machine from the the Epson driver repository but all to no avail.
My machine details are :-
O.S. Ubuntu 12.04
c.p.u. Celeron ® G550 @ 2.60 GHz x 2
OS- 32 bit
Memory 3.6 GiB

I would be most grateful for some assistance, please
Oh, sod it.
catgate
LXF regular
 
Posts: 1044
Joined: Wed Jul 19, 2006 6:45 pm
Location: Just over there, in that corner.

Postby ferrari » Sat May 24, 2014 12:04 am

Hi catgate.

Some more information might be useful.

1. Can you tell us how it is connected? (USB, wifi, wired ethernet)

2. After you installed the deb package, did you then configure the printer? For example, I usually use the CUPS web interface for this:

http://localhost:631/admin

You didn't mention whether the printer was detected during configuration. (The CUPS utility allows manual configuration if necessary.)
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am

Postby catgate » Sat May 24, 2014 11:34 am

Thank you for that, ferrari.

I have just returned from the Goole chandler where I returned the recalcitrant WF-315 and picked up a new Epson WF-2510WF (it says on the box).
Just what lies ahead I know not.
The XP-315 was connected via USB, as have been all my past printers.

"printers.http://localhost:631/admin" is new to me (I think). It looks interesting.

EXCELSIOR
Oh, sod it.
catgate
LXF regular
 
Posts: 1044
Joined: Wed Jul 19, 2006 6:45 pm
Location: Just over there, in that corner.

Postby catgate » Sat May 24, 2014 2:43 pm

I dare hardly write this...but....I have a WF-2510 which appears to be "fully displaying it's function"

Re. "printers.http://localhost:631/admin"

I have seen it before, but it is quite some time ago. I used it and it may well be that therein lies the root of success.
It has made a happy man very old.

Thanks, ferrari.
Oh, sod it.
catgate
LXF regular
 
Posts: 1044
Joined: Wed Jul 19, 2006 6:45 pm
Location: Just over there, in that corner.

Postby ferrari » Sat May 24, 2014 9:44 pm

Happy to have been of help. I hope your printer lasts a bit longer this time. :)

BTW, the web interface is native to CUPS, and so can be used regardless of distro being used. That is why I suggested it, as it's what I'm most familiar with.
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am


Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest