Feedora 16 -H-P 880c not working on USB

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

Feedora 16 -H-P 880c not working on USB

Postby Cagere » Tue May 06, 2014 7:38 am

Hi All . I have an old H-P Deskjet 880c which works fine on another linux machine via the parallel connection. I now want to use it instead with a fedora 16 box via the USB connection. Plugging in the USB lead results in the printer being detected and various programs being downloaded. The setup process seems to complete without error messages and the printer can be seen in "Printers". However it will not print (even the test print). The settings are as below.

Description HEWLETT-PACKARD DESKJET 880C
Location Silver.localdomain
Device uri usb://HP/DESKJET%20880C?serial=ES923141Q0FA
Make and model HP Deskjet 880c, hpcups 3.12.10a
Printer state Idle - Processing page 1...

I have checked that CUPS is running, can anyone suggest how to fix the problem? Cagere
Cagere
 
Posts: 44
Joined: Sat Jun 24, 2006 1:30 pm
Location: Norfolk UK

Postby ferrari » Wed May 07, 2014 2:30 am

It probably depends on which driver you're using. I had a quick look at the HPLIP web page (which suggests no USB support) for this model with the hplip driver at least

http://hplipopensource.com/hplip-web/mo ... _880c.html

However, this model appears to be supported by the gutenprint driver as well.

I would try configuring using the CUPS web interface

http://localhost:631

Administration > Add Printer (follow the prompts given), and select 'HP Deskjet 880C - CUPS+Gutenprint' driver when choosing model. Try a test print and see how that goes.
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am

Postby Cagere » Wed May 07, 2014 7:57 am

Hi Ferrari. Thanks for the reply. I have tried re-installing with Gutenberg as you suggested but still no print! New settings are shown below.

Description HP DESKJET 880C
Location Silver
Device Uri usb://HP/DESKJET%20880C?serial=ES923141Q0FA
Make and model HP DeskJet 880C - CUPS+Gutenprint v5.2.9
Printer state Idle - Printing page 1, 33%

I will be away from home until next Tuesday so I won't be able to try any other options till then. Cheers
Cagere
 
Posts: 44
Joined: Sat Jun 24, 2006 1:30 pm
Location: Norfolk UK

Postby ferrari » Wed May 07, 2014 8:50 am

I note that the printer URI is reported as

Code: Select all
Device uri usb://HP/DESKJET%20880C?serial=ES923141Q0FA


I could be wrong, but I think that the correct URI should look something like
Code: Select all
hp:/usb/DeskJet_880C?serial=ES923141Q0FA

which would then invoke the 'hp' backend instead.

Try detecting with
Code: Select all
hp-probe -busb

and note what is reported.

You could also try configuring using the 'hp-setup' utility
Code: Select all
sudo hp-setup
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am

Postby Cagere » Wed May 07, 2014 10:01 am

Thanks Ferrari. I will try this next week. I'm Just off to Yorkshire.
Cagere
 
Posts: 44
Joined: Sat Jun 24, 2006 1:30 pm
Location: Norfolk UK


Return to Hardware

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests