Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Graphics problem

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
stuarte9



Joined: Mon Mar 08, 2010 5:03 pm
Posts: 53
Location: Scotland

PostPosted: Tue Apr 22, 2014 11:50 am    Post subject: Graphics problem Reply with quote

Hi all,

I'm currently using openSUSE 13.1. Two screens after the "Welcome to GRUB" screen the system displays the following.

"vga=0x307 is deprecated. Use set gfxpayload=1280x1024x8, 1280x1024, before linux command instead."

The system is using an old NVIDIA gfx5200 with 256 MB on-board RAM which handles the KDE cube desktop just fine.

I've looked in .bashrc and .profile but to no avail. Where can I find this linux command ?

Thanks in advance for any help you may be able to give with this.

Stuart
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Tue Apr 22, 2014 11:57 am    Post subject: Reply with quote

This is a message from the kernel telling you that you are specifying the boot screen resolution on the old way. You can safely ignore it but if you want to get rid of it you will have to edit your GRUB config to use gfxpayload instead of vga.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
stuarte9



Joined: Mon Mar 08, 2010 5:03 pm
Posts: 53
Location: Scotland

PostPosted: Wed Apr 23, 2014 4:23 pm    Post subject: Reply with quote

Hi Nelz,

Thanks for the quick reply. I've done a bit of web searching and it seems that I have to set GRUB_GFXMODE. Nothing I've seen so far mentions gfxpayload, although the two names hint that the latter may be a more modern replacement for the former. Any thoughts on that ?

The reason that I think(!) that I need to do this is that I've found openSUSE 13.1 to be somewhat unstable. The KDE desktop locks up at least once at the start of a work session. The only way to retrieve normal working is to perform at least one warm reboot. I've since been able to reduce the instability a bit (but not cure the problem!) by setting the current router to factory defaults.

I've also been wondering if this misbehaviour has something to do with the router I'm now using. At the beginning of February I both changed my ISP (who required that I use "their" router) and did a first install of openSUSE 13.1. The system has been unstable since then. I never(!!) had this instability problem with openSUSE 12.3 used with the router from my previous ISP.

Lastly, how do I go about editing/configuring GRUB2 ? The aforementioned web search seemed to indicate use of a command called "grub2-mkconfig". Given the criticality of grub and my lack of experience of working in this area, I'm understandably nervous of borking the system. Any thoughts/advice on this ?

Thanks again for your help. It is much appreciated.

Stuart
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Wed Apr 23, 2014 5:37 pm    Post subject: Reply with quote

This has nothing to do with either KDE or your router. All it does is set the resolution for the boot console or splash screen. The message is purely a warning that the vga= syntax is deprecated, it still works fine. If you are at all nervous about changing boot parameters, I'd stick to "if it ain't broke, don't fix it".

If you do want to change it, you need to edit /etc/defaults/grub and replace the vga parameter with the one suggested in GRUB_CMDLINE_LINUX_DEFAULT. Then generate a new boot menu with

Code:
grub2-mkconfig -o /boot/grub/grub.cfg


Alternatively, you can test the option by pressing e at the boot menu, make the change and press F10 to boot it. That way, if it doesn't work, you can just reboot and the change will disappear.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
stuarte9



Joined: Mon Mar 08, 2010 5:03 pm
Posts: 53
Location: Scotland

PostPosted: Wed Apr 30, 2014 11:12 am    Post subject: Reply with quote

Good morning Nelz,

Thanks for the follow-up.

For the last few days I've been using "e" at the grub boot menu, as per your suggestion, to edit grub on a temporary basis. As per the systems original message I set the gfxpayload to 1280x1024x24,1280x1024. I also removed the "vga=..." setting from the end of the line that started with linux and pressed F10 to continue booting.

This seemed to get rid of the original "vga deprecated" message at boot-up, so this morning I bit the bullet, logged in as root and used "Kate" to edit /etc/default/grub. Once again I set the gfxpayload to 1280x1024x24,1280x1024 and removed the "vga=..." setting from the end of the line that started with linux. This was saved and then, in a terminal, having cd'ed to /etc/default I issued "grub2-mkconfig -o /boot/grub/grub.cfg, as per your suggestion.

The rebuild of grub seemed to proceed without the generation of any error or warning messages. However, on rebooting the system the original "vga deprecated" message reappeared. Once again logging in as root and cd'ing to /etc/default I used "less" and thereby found out that grub.old and grub.original both have the "vga=..." setting intact.

Do I now have to manually edit grub.old and grub.original as well ?
Should I even be going near these files ?
Aren't these files somehow generated by the grub2-mkconfig process ?

The system still boots, touch wood. I can still use the desktop and even get on the web, as you can see. This means that thanks to your guidance I have not yet borked the system. Smile

Any further help that you can give with this would be very much appreciated.

Stuart
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Thu May 01, 2014 1:25 pm    Post subject: Reply with quote

grub.old and grub.default are probably backup files, they shouldn't affect the menu. Does grub.cfg still contain the vga setting?
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
stuarte9



Joined: Mon Mar 08, 2010 5:03 pm
Posts: 53
Location: Scotland

PostPosted: Fri May 02, 2014 10:55 am    Post subject: Reply with quote

Good morning nelz,

Thanks for another follow-up.

This morning I logged in as root and had a scout around. Using "less" I've found out that in the file /boot/grub/grub.cfg, the line beginning with linux does not have the vga setting. However, in the file /boot/grub2/grub.cfg, the line beginning with linux does have the vga setting.

So, where do I go from here ?

As always, thanks in advance for any further help you can give with this.

Stuart
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Fri May 02, 2014 12:48 pm    Post subject: Reply with quote

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg


You updated the wrong file. It's a bi confusing because some distros put GRUB2 in /boot/grub and some in /boot/grub2 - to avoid trampling legacy GRUB files.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
stuarte9



Joined: Mon Mar 08, 2010 5:03 pm
Posts: 53
Location: Scotland

PostPosted: Mon May 05, 2014 11:54 am    Post subject: Reply with quote

Good morning nelz,

Well, the edits are done and the "vga deprecated..." message no longer appears during bootup. Also, the system does appear to be a bit(!!) more stable. So, thank you for all your help with this.

Now, if I could only discover why I'm still getting the occasional desktop lockup. Sad

Thanks again.

Stuart
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast