Mint 13 XFCE Graphics problem

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Mint 13 XFCE Graphics problem

Postby Crispy » Tue Jun 11, 2013 3:05 pm

Hi,

I recently installed Mint 13 XFCE and have been experiencing a few issues. My graphics card is a Nvidia GT240 and i'm using the nvidia-experimental-304 driver (i also get the same problems when using the recommended driver) running two monitors.

When I log into my computer, I always get the default set up - the desktop is the same on both monitors. I have to open the nvidia-settings and change the set up so that the desktop is extended across the two monitors. I then save the X configuration file and reboot. Only to find that when I log back in, the configuration is back to the default - desktop is the same on both monitors. It mustn't be saving the xorg file correctly, so I tried deleting it and saving, and also merging but it always behaves the same, I always get the default set up when I restart.

Additionally, if I lock the screen and leave it for a while I cannot get back to the desktop without restarting. I can get back to the desktop if I try when the screensaver is still active, however if I leave it for a while (like overnight) i can never get back to the desktop.

I am totally confused on the above two issues and so any help is greatly appreciated.

Thanks,
Chris
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby nelz » Tue Jun 11, 2013 3:21 pm

AFAIR you need to run nvidia-settings as root (or with sudo) to be able to save an xorg.conf.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Crispy » Tue Jun 11, 2013 4:20 pm

Thank you for your reply Nelz, if I run it without sudo I am prompted to authenticate it and it seems to save it - I get no errors. I have tried running it as sudo though and the only difference is that I'm not prompted to enter a password - I get no errors and on reboot it still returns to the default config.

Thanks,
Chris
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby Rhakios » Tue Jun 11, 2013 5:30 pm

Have you had a look at the xorg.conf file after you've saved it to make sure it looks okay? ISTR when I still had two monitors, rather than one big one, that I had to fiddle a little with the xorg.conf file to get it to work properly, if there are errors as X starts it just reverts to a default state.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby nelz » Tue Jun 11, 2013 9:04 pm

You can also look in /var/log/Xorg.0.log to see what X is actually doing as it starts up.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Crispy » Wed Jun 12, 2013 11:08 am

Thank you for your replies Rhakios and Nelz.

In looking at the xorg.conf file, it didn't seem correct to me - there wasn't an option for TwinView and it seemed to list too many metamodes. In looking at the Xorg.0.log, I noticed that it said:

Setting mode: VGA-(blah) +0+0, DVI-I-(blah) +0+0

so I think that having +0+0 for both is what is causing the problem - although I am not sure. As I am also having issues with the monitor sleeping, I decided to purge all nvidia drivers - nvidia-current, nvidia-experimental-304 and nvidia-experimental-310 - and install the latest version downloaded from the Nvidia website.

When I ran the .run file, I got a message saying that the distribution pre-install script wasn't available but I continued with the installation anyway (I attempted, before this, to install the experimental-310 drivers from the Additional Drivers menu option and got an error, so perhaps this is related to the pre-install script not being available?). After the install I rebooted but just got a load of pixelation and then it froze - I had this before the nvidia drivers were installed, something to do with the KMS - so after <Alt>+<Sys Rq>+REISUB, I added the "nomodeset" boot parameter and managed to get to my desktop.

I then opened the nvidia-settings dialog again, and edited the configuration and saved it to the xorg.conf file. Again I checked the file and noticed that there was still no TwinView option, however it had correctly added the +1680+0 to the second monitor. I added manually the:

Option "TwinView" "1"

to the screen section of xorg.conf and rebooted. However, when I logged back in I still had the same single desktop copied on both monitors - no TwinView. I checked to see if the xorg.conf file wasn't being overridden and it wasn't. It still had all the correct parameters in it.

Checking the Xorg.0.log file showed that again I had the line:

Setting mode: VGA-(blah) +0+0, DVI-I-(blah) +0+0

So the xorg.conf file isn't being used at all? Is it something to do with the nomodeset boot param that I've added to grub?

I'm totally confused, this makes no sense to me and so any help is greatly appreciated!
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby nelz » Wed Jun 12, 2013 2:15 pm

Does the log file show the /etc/X11/xorg.conf file being loaded?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Crispy » Wed Jun 12, 2013 4:20 pm

Yeah in the log file it definitely says "Using config file: /etc/X11/xorg.conf" then shortly after that it says:

(II) NVIDIA(0): Setting mode "CRT:1680x1050+0+0,DFP:nvidia-auto-select+1680+0"

which is the correct setting but then shortly after that it says:

(WW) NVIDIA(0): Option "TwinView" is not used

which is not good because I'm pretty sure TwinView is what I need. Then towards the bottom it says:

(II) NVIDIA(0): Setting mode "VGA-0: 1680x1050 @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}, DVI-I-1: nvidia-auto-select @1680x1050 +0+0 {ViewPortIn=1680x1050, ViewPortOut=1680x1050+0+0}"

which, as it comes later, surely overrides what was done previously? I'm still having the problem of being unable to wake the computer after the monitor has gone to sleep as well. I'm guna try and blacklist the nouveau driver see if that helps :S I kind of feel out of depth a bit here so I'm trying anything.

EDIT: I've also just tried changing the position in the nvidia-settings dialog. Instead of using absolute, I changed the position of the one monitor to be "Right of" the other one. This still doesn't work and so I still have a copied desktop on the two monitors.
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby nelz » Wed Jun 12, 2013 5:58 pm

Do you have anything in /etc/X11/xorg.conf.d?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Rhakios » Wed Jun 12, 2013 6:44 pm

If it's any help, here's the last working xorg.conf I have backed up from when I had two monitors. I notice that only one monitor is defined and nvidia autoselects another to the right.

Code: Select all
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@allspice)  Fri Mar 30 15:25:24 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics L1811S"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1280+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


A much older xorg.conf I have would probably not be of much help as it's littered with SaX options, which would only confuse things.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby Crispy » Fri Jun 14, 2013 9:35 am

I don't seem to have /etc/X11/xorg.conf.d, however xorg.conf.d does exist in /usr/share/X11/ .. Having a look in the directory gives:

10-evdev.conf
11-evdev-quirks.conf
11-evdev-trackpoint.conf
50-synaptics.conf
50-vmmouse.conf
50-wacom.conf
51-synaptics-quirks.conf

As far as I can tell these files are only for input devices. Just to give some info, the evdev ones contains config's for things like keyboard, pointer, touchpad, tablet, touchscreen etc.. 50-synaptics.conf is for touchpads, I can't tell what 50-vmmouse.conf is for but it only contains a single Section "InputClass" entry.. 50-wacom.conf is for wacom devices by the looks of things and finally 51-synaptics-quirks.conf are for touchpad quirks.

As far as I can tell there isn't anything in there relating to monitors, or screen layout or anything like that only mice, keyboards, touchpads etc..

Thank you for posting ur xorg.conf Rhakios. I have just re-wrote the xorg.conf file from within the nvidia-settings file and compared it to your post. The only differences, apart from the names of the cards and monitors, occur in the Screen section. In my xorg.conf file created by nvidia-settings, it doesn't contain:

Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"

Instead it has:

Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "CRT-0"

Also there is a difference in the metamodes option, in that I have:

Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1680+0"

I am just about to manually add the two options relating to TwinView and add CRT-0 and DFP-0 instead of CRT and DFT in the metamodes. I'll let you know what happens.


EDIT: Ok so I tried what I said above and it did absolutely nothing. The thing that is most strange is that desktop layout does not reflect the xorg.conf file. The config file clearly states that the layout should have one monitor on the right of the other - basically TwinView (which is also stated in the config file), yet that is not what is actually displayed. I looked more closely at the /var/log/Xorg.0.log file that nelz suggested and it clearly shows the xorg.conf being used and using the files in /usr/share/X11/xorg.conf.d/ directory (there are no files in that directory relating the monitor layout).

The log file states that the metamode layout is being verified and then sets that mode:

NVIDIA(0): Setting mode "CRT:nvidia-auto-select+0+0,DFP:nvidia-auto-select+1680+0"

It then states that the option TwinView is not used? Which makes no sense because running nvidia-settings has an option saying "TwinView". On top of that, the log file then says:

NVIDIA(0): [DRI2] Setup complete

So it's setting the correct mode for the layout (eventhough TwinView is being ignored) and completing the set up - fantastic! Then if we scroll down to the bottom of the log file, it randomly starts reconfiguring the layout by setting the mode:

NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1680x1050 +0+0, DVI-I-1: nvidia-auto-select @1680x1050 +0+0"

which is clearly wrong because both monitors are on top of each other (+0+0) - the graphic in nvidia-settings shows both monitors on top of each other after a reboot. Also there is no message in the log file to say what config file it is using for that layout.

Sorry if I sound frustrated but this makes no sense to me what so ever and is driving me round the bend!

Thanks,
Chris
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby Rhakios » Fri Jun 14, 2013 5:19 pm

Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1680+0"


Surely this line should be:

Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1680+0"

if using twinview. I'm not sure what DFP means. Although xorg.conf uses the term CRT, neither monitor was actually a cathode ray tube device, both were TFT monitors. Sadly as I lost the one monitor around the end of last year, I don't have any log files going back far enough to show how xorg handled things for me.

Edit: Okay, so "anything attached to a 15 pin VGA connector is regarded by the driver as a CRT. "DFP" should only be used to refer to digital flat panels connected via a DVI port.". Hmm, while one monitor was connected via a DVI port, it was using a DVI to VGA adaptor, hence it was really a VGA monitor (and thus CRT).
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby Crispy » Fri Jun 14, 2013 5:35 pm

Sadly as I lost the one monitor around the end of last year, I don't have any log files going back far enough to show how xorg handled things for me.


That's ok no worries, I think I am getting slightly closer to the problem. One of my friends is running the exact same card, with the same version of nvidia drivers (roughly - their both 310, mine is 310.14, his is 310.44).. I asked him to run:

Code: Select all
cat /var/log/Xorg.0.log | grep -i 'Setting mode'


His only returned a single line

NVIDIA(0): Setting mode "CRT:nvidia-auto-select+0+0,DFP:nvidia-auto-select+1680+0"

However mine returns two:

NVIDIA(0): Setting mode "CRT:nvidia-auto-select+0+0,DFP:nvidia-auto-select+1680+0"
NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1680x1050 +0+0, DVI-I-1: nvidia-auto-select @1680x1050 +0+0"


What I found interesting was that in the second line, the monitors are called VGA-0 and DVI-I-1. Running

Code: Select all
xrandr -q


The monitors were called VGA-0 and DVI-I-1.. which made me think.. so I ran:

Code: Select all
sudo xrandr --output VGA-0 --auto --rotate normal --pos 0x0 --output DVI-I-1 --auto --rotate normal --right-of VGA-0


to get the desired layout and then ran:

Code: Select all
cat /var/log/Xorg.0.log | grep -i 'Setting mode'


which returned 3 lines, the same two as before and a new one:

NVIDIA(0): Setting mode "CRT:nvidia-auto-select+0+0,DFP:nvidia-auto-select+1680+0"
NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1680x1050 +0+0, DVI-I-1: nvidia-auto-select @1680x1050 +0+0"
NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1680x1050 +0+0, DVI-I-1: nvidia-auto-select @1680x1050 +1680+0"

The last two lines match each in the naming of the monitors and the command - only difference is the position +1680! Therefore it would appear that X is causing an issue, Nvidia is setting everything correctly then X replies "NAH!!" and resets everything lol.
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby Rhakios » Fri Jun 14, 2013 6:39 pm

Weird. Searching around a bit, I notice a few people having problems with twinview on Mint 13. I don't know if the first answer given here is any use, but it offers a different configuration option for xorg.conf. I'm not sure if his overall procedure might help things "stick". :?
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby Crispy » Tue Jun 18, 2013 1:03 pm

Thanks for that link Rhakios, I tried the TwinViewOrientation option that they mention in that post and followed their steps exactly but I still get the same behaviour - it doesn't keep the settings on reboot.

I think I am sure now that it is due to the fact that I get two lines in the log file:

NVIDIA(0): Setting mode "CRT:nvidia-auto-select +0+0,DFP:nvidia-auto-select +1680+0"
NVIDIA(0): Setting mode "VGA-0: nvidia-auto-select @1680x1050 +0+0, DVI-I-1: nvidia-auto-select @1680x1050 +0+0"


I think if I put the command:

Code: Select all
xrandr --output VGA-0 --auto --rotate normal --pos 0x0 --output DVI-I-1 --auto --rotate normal --right-of VGA-0


into a script that run when booting then I should get the correct layout. However, I am unsure of how to do this?

I think I may have got around the problem that I found when the monitor went to sleep - I think I've turned off DPMS, I am going to test it this afternoon seen if it works.
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests