what the...

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

what the...

Postby heiowge » Sat Sep 29, 2012 1:21 pm

Image

Why is 1 core at full speed, but the rest are only at 800mhz? Is it that one only is being used, or that the rest have a fault?
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby nelz » Sat Sep 29, 2012 5:08 pm

It's probably the kernel scheduler reducing the speed until it's needed. If your kernel uses the on-demand governor, this is to be expected.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8532
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby heiowge » Sat Sep 29, 2012 5:17 pm

Thanks nelz. Any idea if Mint 13 includes this?
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby nelz » Sun Sep 30, 2012 10:11 am

Code: Select all
zgrep CPU_FREQ /proc/config.gz


should show you which cpufreq options are enabled in your kernel.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8532
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby heiowge » Sun Sep 30, 2012 2:41 pm

nelz wrote:
Code: Select all
zgrep CPU_FREQ /proc/config.gz


should show you which cpufreq options are enabled in your kernel.



Typed that. Got this:

gzip: /proc/config.gz: No such file or directory :?
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby Paradigm Shifter » Sun Sep 30, 2012 3:29 pm

It's called Cool 'n' Quiet, the AMD equivalent to Intel Speedstep.

It's BIOS controlled, and in my experience great if you want to decrease idle power draw, but a nightmare if you've got any software that is reliant on CPU clock to control its internal timing count - Unreal Tournament engine games spring to mind here; if you install them with the CPU 'idle' they'll run in fast-forward due to the CPU clocking up to full speed when the game actually runs.

Run linpack or something similar, and you'll see all cores at their rated 3200MHz. :)

It's interesting to see the evolution of power saving tech for CPUs - initially it was a bit of a sledgehammer solution (all cores clocked up or down) then it evolved to a load-based scenario (all cores have independent clock states depending on load) and the latest and greatest versions (semi-)intelligently work out how much a core can be overclocked based on load, TDP and temperature.

So, no, there's no fault there. It's doing what it's designed to. If you want it running full speed all the time, disable Cool 'n' Quiet in the BIOS. :)
User avatar
Paradigm Shifter
 
Posts: 84
Joined: Sat May 19, 2012 12:16 pm

Postby nelz » Sun Sep 30, 2012 6:19 pm

heiowge wrote:gzip: /proc/config.gz: No such file or directory :?


Stupid distros trying to hide the kernel config.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8532
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby el chapulín » Mon Oct 01, 2012 1:06 pm

As it's a Debian based distro this should do it:

Code: Select all
$ grep -i cpu_freq /boot/config-`uname -r`
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Postby heiowge » Mon Oct 01, 2012 2:55 pm

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby el chapulín » Mon Oct 01, 2012 4:21 pm

Well the performance governor is configured as the default on that system... but you said that different cores are at different speeds, which as far as I know is not normal cpfreq behaviour - nor is it normal for speedstep or cool n quiet as far as I know.

The cores being locked to 800MHz could be a symptom of a lack of "dual power plane" support on the motherboard. You should verify this first and that your board is definitely an AM3 board and not an AM2+ or "AM3 optimised" board... your CPU, assuming it's the one in your signature certainly requires an AM3 board to realise it's full potential, but you haven't stated what motherboard you have.
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Postby heiowge » Mon Oct 01, 2012 7:13 pm

Its an ASRock M3A770DE. I hope that means more to you than it does to me. The manual says "Support for socket AM3 processors: AMD Phenom II X4 / X3 / X2 (except 920 / 940) and Athlon II X4 / X3 / X2 processors).
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby heiowge » Mon Oct 01, 2012 7:25 pm

Maybe these will help?

Image

Image

Image
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
User avatar
heiowge
LXF regular
 
Posts: 1906
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby el chapulín » Tue Oct 02, 2012 7:30 am

Your board is ok. As a diagnostic test can you disable frequency scaling in the BIOS setup (if you're not sure how read the motherboard manual) and see if that causes all cores to return to their correct speed.
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Postby Paradigm Shifter » Tue Oct 02, 2012 11:50 am

Set 'Cool 'n' Quiet' to [Disabled]. Watch all CPU cores run at 3200Mhz.

Modern CPUs are designed in such a way as to allow cores to clock independently based on load.

This Anandtech review, particularly the second page, goes into a little more detail about 'Turbo' and power states on the CPU cores.

Was my previous post a figment of my imagination? You're looking for a problem when there isn't one.
User avatar
Paradigm Shifter
 
Posts: 84
Joined: Sat May 19, 2012 12:16 pm

Postby el chapulín » Tue Oct 02, 2012 12:49 pm

He has the performance governor enabled so all cores should at the highest clock, that is the issue.

I agree though, disabling cool and quiet should be the next step.
el chapulín
 
Posts: 50
Joined: Fri Sep 07, 2012 1:13 pm

Next

Return to Help!

Who is online

Users browsing this forum: No registered users and 3 guests