Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Switched from Nouveau to nVidia, Gnome problem [SOLVED]

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
splurben



Joined: Thu Nov 03, 2011 12:00 am
Posts: 2
Location: Augusta, Western Australia

PostPosted: Fri Sep 07, 2012 7:13 am    Post subject: Switched from Nouveau to nVidia, Gnome problem [SOLVED] Reply with quote

I'm running a Gentoo AMD64 System, kernel 3.5.3-gentoo

I am on Gnome 3, my shell version is 3.2.2.1

I was using Nouveau for my nVidia card but I got really tired of all the tearing on video so I switched back to the nVidia proprietary drivers (304.43).

The proprietary nVidia drivers are definitely installed and running.


During the switch Gnome 3 dropped into fallback mode and I cannot for the life of me find a way to restore full Gnome 3.

I have another Gentoo AMD64 system with the exact same video card [GeForce 8500 GT] and it's using Gnome 3 Shell without fallback.

I really like the clean Gnome 3 interface and keyboard integration it provides.

How the heck do I get Gnome to forget about fallback mode, I've tried tons of things, I've reinstalled Gnome, removed all the configuration files I can find or have located on various other posts relating to Gnome 3 and I'm just totally stumped.

Can anyone help with this? Please.
Back to top
View user's profile Send private message
splurben



Joined: Thu Nov 03, 2011 12:00 am
Posts: 2
Location: Augusta, Western Australia

PostPosted: Tue Sep 11, 2012 5:10 am    Post subject: OpenGL Configuration Reply with quote

Although X11 was loading the nVidia proprietary driver, it wasn't sending OpenGL to nVidia card.

Solution (on Gentoo):
Code:
#eselect opengl set nvidia


It is fair to note that I had already uninstalled Gnome completely from the computer and deleted ALL the Gnome configuration files in /ETC, /VAR/LIB, and my user directory ~/ before this as well. I don't know if that was needed but I hope it wasn't for the sake of anyone else that hits this problem 'cause it took for f-ing ever as I'm not a Gnome developer.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8439
Location: Warrington, UK

PostPosted: Tue Sep 11, 2012 8:31 am    Post subject: Reply with quote

It sounds like you may have installed an update to xorg-server and that reset the opengl link back to x11. Alternatively, there have been ebuilds for software that needed the X11 opengl to build against, so they reset the link for the duration of the compile. An aborted compilation may leave the wrong link in place.

Edit: I've re-read your original post, it appears that you never selected the nvidia opengl option. The elog message after installing the nvidia driver should have told you to do this.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast