Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

fstab Problem! Can't access my system, emergency mode only
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Fri Aug 17, 2012 8:48 pm    Post subject: fstab Problem! Can't access my system, emergency mode only Reply with quote

I can't do anything on my computer

Dear all,
I was previously experimenting problems, after upgrading from Opensuse 11.4 (KDE) to 12.1 (KDE) in which I was unable to edit an external HD I had been using before without any issues. In 12.1 I was able to read and copy files from it to the main drive, but was unable to edit anything (save changes, delete or add files etc.) within the external drive. Also, the mentioned external drive (NTFS) appeared as a windows partition under "Windows D". (In 11.4, it simply showed as part of "media" directory).

So I went on the official forum, and after I was asked to show the fstab, I was advised to introduce some changes to the fstab.

from code line:
/dev/disk/by-id/ata-WDC_WD5000AAJS-00A8B0_WD-WMASY0638851-part1 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8,nofail 0 0
- I was advised to set it to "default", which I did...

For a moment, I was able to regain full functionality from the external drive and everything was going really well. I even shut down for a few hours and turned the computer back on with no problems.

However, since the following morning I have been unable to boot to my system!! After a longer than usual booting time, I am greeted with a screen showing the ongoing boot processes, ending with the following message (manually typed from my pc screen to my laptop and preceded by more text):

Started /home [ OK ]
[ 11.541335] ALSA via82xx.c:591 codec_read: codec 0 is not valid [0xfe0000]
[ 11.552311] ALSA via82xx.c:591 codec_read: codec 0 is not valid [0xfe0000]
[ 11.568750] ALSA via82xx.c:591 codec_read: codec 0 is not valid [0xfe0000]
[ 11.576408] ALSA via82xx.c:591 codec_read: codec 0 is not valid [0xfe0000]
Dependency failed. Aborted start of /windows/D [ ABORT ]
Welcome to emergency mode. Use "systemct1 default" or ^D to activate default mode.
Give root password for login;

- I entered my root password, then got:

linux-hrmj: ~ #

* I was advised to use installation DVD but could not get it to work.
* Then I was advised to look into the fstab "vi /etc/fstab" to add "#" to the beginning of the line "/windows/D" in "/etc/fstab".

I can see the file and hover through it with the arrow keys, but am unable to introduce any changes.

It seems that at the other forum they are too busy or just gave up on me. Unfortunately I am not an expert in Linux and not very experienced with its inner functions...

In the meantime I am loosing hours of productivity.

Please...What can I do to get my system back?

Thank you very much for your help and suggestions!
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8467
Location: Warrington, UK

PostPosted: Fri Aug 17, 2012 8:58 pm    Post subject: Reply with quote

That's because vi is the spawn of the devil and you need to switch this text editor into editing mode before you can actually edit any text with it, then switch back out to save your changes. The simple answer is to use nano instead of vi, where a simple Ctrl-X saves your changes.

You don't say how you changed /etc/fstab, you added default, but where? However, I think you should remove the line for this disk entirely, or comment it out. It appears the installer thought this was a fixed drive, hence adding it to the fstab. Removable drives don't belong in here, they are automatically mounted under /media with suitable permissions for the user running the desktop, just like you had with your previous installation.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Fri Aug 17, 2012 10:01 pm    Post subject: Reply with quote

Hello Nelz! Thank you very much for your reply.

The earlier change to fstab I did was done while my only problem was not being able to edit my external HD. Everything else was working fine. I accessed it by:

"Alt-F2: kdesu kwrite /etc/fstab"

I then replaced the last portion of the text in "windows D" line (users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8,nofail) with "default"

After being unable to access my pc, I also tried using nano (as advised on another forum) by "nano /etc/fstab", but it then showed the message "if 'nano' is not a typo you can use command....."
I just tried again with no avail. Am I writing it wrong or maybe I just don't have nano??
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8467
Location: Warrington, UK

PostPosted: Fri Aug 17, 2012 10:17 pm    Post subject: Reply with quote

There are three problems here. The first is that you have a removable drive in fstab, they don't belong there and it is why you could not write to it (devices in fstab are mounted by root). The second is that you added an incorrect option to the fstab line - it is defaults not default, and it wouldn't have made the disk writable by a user anyway (the correct approach would be to fix the umask setting). Finally, you don't have nano installed, so you'll have to use vi. Press i to enter insert (edit) mode, add a # to the start of the offending line. Press Esc to go back to command mode and enter :wq to save and exit.

Vi makes the Windows idea of pressing the Start button to shutdown seem positively intuitive Shocked
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Fri Aug 17, 2012 10:51 pm    Post subject: Reply with quote

Thanks and agree! trying it out now!
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Fri Aug 17, 2012 11:21 pm    Post subject: Reply with quote

I hit "i", added "#" to the beginning of the line, then ESC and :wq

Restarted twice and nothing happened. I continue to get the same message prompting me to give root password for emergency mode. This is getting really frustrating... what else can I do?..

(Maybe my mistake is here? I placed # :
"# /dev/disk/by-id/ata-WDC_WD5000AAJS-00A8B0_WD-WMASY0638851-part1 /windows/D ntfs-3g defaults 0 0

PS: It always said "defaults" and nor "default", my mistake in copying..)

Thanks again!
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8467
Location: Warrington, UK

PostPosted: Fri Aug 17, 2012 11:29 pm    Post subject: Reply with quote

When you get to the emergency command prompt, what does running
Code:
mount -a
report?
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Fri Aug 17, 2012 11:57 pm    Post subject: Reply with quote

I get a rather long text.
it states:

ntfs-3g: failed to access volume '/dev/disk/by-id/ata-WDC_WD5000AAJS-00A8B0_WD-WMASY0638851-part1' : No such file or directory

ntfs-3g 2011.4.12 integrated FUSE 27 - Third Generation NTFS Driver
configuration driver type 1, XATTRS are on, POSIX ACLS are off

- then there 4 lines showing copyrights, then:

Usage: ntfs-3g [-o option [,...]] <device| image_file> <mount_point>

Options: ro (read-only mount). remove_hiberfile, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in manual (type: man ntfs-3g)

Example: ntfs-3 /dev/sda1 /mnt/windows

News, support and information: http://tuxera.com

- This was copied from the screen to my laptop by hand.
Thanks!
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8467
Location: Warrington, UK

PostPosted: Mon Aug 20, 2012 9:16 am    Post subject: Reply with quote

It is still trying to mount the external drive, all lines referring to it need to be removed or commented.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Mon Aug 20, 2012 3:02 pm    Post subject: Reply with quote

Hello again Nelz and thanks again.

Yes. It reads:
Dependency failed. Aborted start of /windows/D
Welcome to emergency mode.............etcetera

Would it be correcto to:
vi /etc/fstab
then just delete the entire line?
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Mon Aug 20, 2012 3:57 pm    Post subject: Reply with quote

I think there has been some progress, though I may have commited some errors these last days while trying to fix things through vi:
After startup, I am now finally prompted to enter my user password at the regular login screen. However, when I enter the password, I get the following message:
"Cannot enter home directory. Using /."

I hit enter, and another screen opens saying: "Call to lnusertemp failed (temporary directories full?). Check your installation." followed by an okay button.

I hit the okey button and greeted once again with the login screen.
Now I entered as root, and was able to enter a session, apparently ok.

Maybe things are getting better?
What should I do now or examine to get back to my main user ?
Back to top
View user's profile Send private message
lobo



Joined: Tue Mar 29, 2011 3:55 am
Posts: 16
Location: Chile

PostPosted: Mon Aug 20, 2012 4:09 pm    Post subject: Reply with quote

I think there has been some progress, though I may have commited some errors these last days while trying to fix things through vi:
After startup, I am now finally prompted to enter my user password at the regular login screen. However, when I enter the password, I get the following message:
"Cannot enter home directory. Using /."

I hit enter, and another screen opens saying: "Call to lnusertemp failed (temporary directories full?). Check your installation." followed by an okay button.

I hit the okey button and greeted once again with the login screen.
Now I entered as root, and was able to enter a session, apparently ok.

Maybe things are getting better?
What should I do now or examine to get back to my main user ?
Back to top
View user's profile Send private message
Dutch_Master
LXF regular


Joined: Tue Mar 27, 2007 2:49 am
Posts: 2438

PostPosted: Mon Aug 20, 2012 4:10 pm    Post subject: Reply with quote

Better? Far from it! It appears your system has some runaway logs or other process that consumes drive space...

Best solution is to re-install, but that might mean you'd loose all data if you haven't backed up or have a separate /home partition.
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1674
Location: Guisborough

PostPosted: Mon Aug 20, 2012 4:22 pm    Post subject: Reply with quote

No No I hear nelz scramming...

Grab hold of a LiveCD and examine your system to see where the space has been used up.
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
Dutch_Master
LXF regular


Joined: Tue Mar 27, 2007 2:49 am
Posts: 2438

PostPosted: Mon Aug 20, 2012 5:12 pm    Post subject: Reply with quote

True, I figured Nelz would be screaming behind (or rather in front of Wink) his screen by now. But examining a Linux system via a Live CD appears to me quite useless if the user performing it has too little knowledge of a Linux system in the first place. That's why I advised the best solution is to re-install. even if that's not what Nelz wants to hear Rolling Eyes
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast