Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bluetooth AWOL on Acer Aspire One 725 w/Lubuntu 12.04 64-bit

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Sat Aug 04, 2012 4:40 pm    Post subject: Bluetooth AWOL on Acer Aspire One 725 w/Lubuntu 12.04 64-bit Reply with quote

I have installed Lubuntu 12.04 64-bit on my Acer Aspire One 725, and finally have almost everything working as it should. One of the major exceptions seems to be Bluetooth. The specifications for the laptop state that the computer comes with Bluetooth 4.0, however Lubuntu seems unable to detect it:
Code:
$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6290]
00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port
00:10.0 USB controller: Advanced Micro Devices [AMD] Hudson USB XHCI Controller (rev 03)
00:11.0 SATA controller: Advanced Micro Devices [AMD] Hudson SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:13.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:13.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] Hudson SMBus Controller (rev 14)
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] Hudson LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] Hudson PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
02:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n
Code:
$ lsusb
'Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 04f2:b335 Chicony Electronics Co., Ltd
Does anyone have a suggestion as to how to get this sorted out? I have unfortunately been unable to find anymore information about the Bluetooth, neither on the Acer site nor on any of the sites that review the laptop.

BTW, I am also looking for a solution to the touchpad being locked at startup, requiring me to Fn-F7 unlock it at every system start. This issue is on all of the distros that I have tried (both 32 and 64 bit).
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3443
Location: Birmingham, UK

PostPosted: Sun Aug 05, 2012 9:30 am    Post subject: Reply with quote

I have had problems with Bluetooth on 12.04, specifically with a USB adapter that I have used for ages.
Bluetooth 4 is based on wifi, so may be built into the wifi adapter.
have you tried installing blueman ?
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Sun Aug 05, 2012 11:53 am    Post subject: Reply with quote

wyliecoyoteuk wrote:
I have had problems with Bluetooth on 12.04, specifically with a USB adapter that I have used for ages.
Bluetooth 4 is based on wifi, so may be built into the wifi adapter.
have you tried installing blueman ?
Thanks for the reply. Blueman gets installed by default both with Lubuntu and Mageia, but the "adapter" and "device" menus are greyed out.
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3443
Location: Birmingham, UK

PostPosted: Sun Aug 05, 2012 2:11 pm    Post subject: Reply with quote

I know that on my lenovo laptop, the bluetooth and wifi are in one combined chip.
I haven't checked the bluetooth out, I'll try later if I get time.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Sun Aug 05, 2012 11:11 pm    Post subject: Reply with quote

Sounds good. BTW, I just tried the following command and the Bluetooth device appears to be AWOL here as well:
Quote:
$ hcitool dev
Devices:
Back to top
View user's profile Send private message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Sun Aug 05, 2012 11:32 pm    Post subject: Reply with quote

Looking at some more threads suggests that I should also post the following output:
Quote:
rfkill list
0: brcmwl-0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
2: acer-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3443
Location: Birmingham, UK

PostPosted: Mon Aug 06, 2012 3:22 pm    Post subject: Reply with quote

Just checked my Lenovo's bluetooth, works fine, but I did have to turn the wifi on in windows first.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Mon Aug 06, 2012 4:51 pm    Post subject: Reply with quote

I have noticed that issue on a number of threads. My laptop came without Win. That was the whole point. I haven't been able to find a Linux based solution to this yet. There are some Ubuntu users that have apparently posted this as a bug already in 11.10. No response has been forthcoming from Ubuntu as far as I have been able to see Sad
Back to top
View user's profile Send private message
towy71
Moderator


Joined: Wed Apr 06, 2005 3:11 pm
Posts: 4257
Location: wild West Wales

PostPosted: Mon Aug 06, 2012 7:05 pm    Post subject: Reply with quote

Could this be something that you need to turn on from the bios?
_________________
still looking for that door into summer
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3443
Location: Birmingham, UK

PostPosted: Mon Aug 06, 2012 8:07 pm    Post subject: Reply with quote

Unfortunately, the trend in laptops is to have as few physical buttons as possible.
my wifi button is F9, but that doesn't seem to work in Ubuntu.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3443
Location: Birmingham, UK

PostPosted: Mon Aug 06, 2012 8:52 pm    Post subject: Reply with quote

http://hal.freedesktop.org/quirk/quirk-keymap-try.html

seems to point a way forward.

Edit:
I just ran updates (needed a lot, I don't update at work because the internet is sooo slow, and I don't use the laptop at home much).and now the f8 key toggles wifi on and off in Ubuntu.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
globetrotterdk



Joined: Sat Jan 21, 2006 8:05 pm
Posts: 77

PostPosted: Tue Aug 07, 2012 9:01 am    Post subject: Reply with quote

wyliecoyoteuk wrote:
http://hal.freedesktop.org/quirk/quirk-keymap-try.html

seems to point a way forward.

Edit:
I just ran updates (needed a lot, I don't update at work because the internet is sooo slow, and I don't use the laptop at home much).and now the f8 key toggles wifi on and off in Ubuntu.
I installed Windows 7 and all of the necessary drivers yesterday. I was then able to pair my Nokia Play 360 speakers. I booted into a Live CD, reduced the Win install and installed Peppermint OS Three (based on Lubuntu 12.04). Bluetooth 4.0 still doesn't work in Linux - the menus "adapter" and "device" are still greyed out in the Bluetooth Manager. I have run the commands again that I have run earlier to identify the device, however I have only found one change:
Code:
$ lsusb
Bus 004 Device 002: ID 0489:e046 Foxconn / Hon Hai
I still don't have much of an idea what is going on, but it seems like this remains first and foremost a hardware driver issue.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast