Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fedora 17 Live Disk caused PC to Re-Boot on Shutdown

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
Old_Timer



Joined: Sun Jul 15, 2012 9:32 pm
Posts: 3
Location: near Evesham

PostPosted: Sun Jul 15, 2012 10:07 pm    Post subject: Fedora 17 Live Disk caused PC to Re-Boot on Shutdown Reply with quote

Hi, sorry for being an old pain but first time reporting fault, bear with me please. I used Fedora 17 Live Disk and when I tried to close down the session could not find a "Shutdown" path similar to Ubuntu versions. So I clicked "Log-off (I am not 100% sure of exact wording) expecting to find another screen which would give me more detailed choice. Sadly there was not one. So I decided to give up and switched the XP PC off. It went off for a few seconds and immediately re-boots. I have found a temporary cure by holding Power button ON and forcing PC to switch off. This is my second bad experience on Linux Format disks the first one was a version of Ubuntu which screwed up PC altogether, my wife was & is NOT very pleased.I have found one suggestion about changing one setting in the registry as follows:-
Press (Windows Key)+R and type in regedit and hit enter. Locate the following key:

Location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Double Click on "PowerdownAfterShutdown"

Then,
Change it to "0" if it is "1" OR
Change it to "1" if it is "0".

And hit Enter.

Mine is showing "0". I am not confident on carrying out this advice yet. Can anyone Help me please. I don't fancy a divorce at 70 years of age over a darn PC and Linux.

Would appreciate so,e suggestions please otherwise I'll have to consider giving up Linux (or at least Fedora), why does it NOT have a shutdown Button to closedown, like Ubuntu.
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1669
Location: Guisborough

PostPosted: Sun Jul 15, 2012 11:33 pm    Post subject: Reply with quote

Editing the Windows ( XP ) registry wouldn't have any effect on missing shutdown option for Fedora.

So, what have you actually done? Did you install Fedora or just load up the Live CD?
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
catgate
LXF regular


Joined: Wed Jul 19, 2006 7:45 pm
Posts: 1037
Location: Just over there, in that corner.

PostPosted: Mon Jul 16, 2012 10:42 am    Post subject: Reply with quote

Have you taken the CD out of the CD drive?
The computer may be set with the CD drive as first boot option.
_________________
Oh, sod it.
Back to top
View user's profile Send private message
jonrob
Site admin


Joined: Thu Jun 30, 2011 4:24 pm
Posts: 43

PostPosted: Mon Jul 16, 2012 3:47 pm    Post subject: Reply with quote

Yes, if you just ran Fedora from the live CD (without "installing to hard disk"), then taking out the disk and rebooting the machine should restore it to the exact same condition it was in before.

Also, Fedora does have a shutdown button, but it is hidden in a very stupid way. To get to the shutdown button, you have to hold down the ALT key as you look at the menu where you found the Log Out option. This is not your fault, but a terrible idea that somebody should have realised by now!

Hope that helps, let us know how you get on.
Back to top
View user's profile Send private message
lok1950
LXF regular


Joined: Tue May 31, 2005 6:31 am
Posts: 1025
Location: Ottawa

PostPosted: Mon Jul 16, 2012 6:29 pm    Post subject: Reply with quote

Those stupid people are the Gnome design team Wink And what they call Gnome 3

Enjoy the Choice Smile
Back to top
View user's profile Send private message
Old_Timer



Joined: Sun Jul 15, 2012 9:32 pm
Posts: 3
Location: near Evesham

PostPosted: Mon Jul 16, 2012 9:56 pm    Post subject: http://www.linuxformat.com/forums/viewtopic.php?t=14967& Reply with quote

I did not install Fedora, I had enough of dual-boot installation when an update went completely wrong on me and prevented us having any PC at all for a fairly long while. so I have stuck with the live disk idea assuming that it would not create many problems, haha!
Not fully understanding how Linux actually works it seemed to me that the "Login" process of Fedora may make a change to the boot process. So I searched the internet and found the comment I stated about editing the registry. I did not mention that in fact another entry did say something about changing the BIOS. Here it is.
-------------------------------
2nd example

This behavior may occur if Windows stops responding during a typical operation or during the shutdown process. By default, the computer is configured to automatically restart when Windows stops responding. To view this setting, follow these steps:
1.Click the Start button, right-click My Computer, click Properties, click the Advanced tab, and then click Settings under Startup and Recovery.
2.Under System Failure, view the Automatically restart check box. If the Automatically restart check box is selected, Windows automatically restarts if the computer stops unexpectedly.
-----------------------
The real problem for me is that at my age I am unable to follow all the full technical ins/outs of how Linux systems actually work at the nuts/bolts S/W level. How the Linux Fedora process actually interfaces with the PC BIOS on-off process will probably always be a mystery to me. I have, however used live disk installations for the past 2-3 years , mainly Ubuntu, and have had no troubles at all, this is the first. In some ways I just want to use them, not re-design them. When It gets me into bother with my good lady though that is a different matter altogether.The lack of a shutdown button seems illogical to an old-stager like me. Many thanks for your time and much needed help.
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1669
Location: Guisborough

PostPosted: Mon Jul 16, 2012 11:13 pm    Post subject: Reply with quote

Did you reboot from Windows to load the Live DVD. I'm guessing that you had to switch on the PC in order to put the DVD in the DVD Drive and it booted to Windows before reading the DVD.

If that was the case then maybe there was a hiccup on rebooting the PC causing it to restart after switching off the PC with holding in the button ( which is safety feature to stop you accidentally switching off the PC by knocking the On/Off button ).

I can't see that switching off the PC as you did should have resulted in a system failure for Windows - Normally the
PC BIOS can be set to restart after say a power cut, I have mine set not to restart - might do some testing to see if just holding the power button in to switch off my PC would be enough for the BIOS to restart it.

Some of the new stuff in Ubuntu is illogic to me hence the reason I'm still using 10.04.
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
Marrea
LXF regular


Joined: Fri Apr 08, 2005 10:32 pm
Posts: 1872
Location: Chilterns, West Hertfordshire

PostPosted: Tue Jul 17, 2012 1:15 pm    Post subject: Reply with quote

jonrob wrote:
Also, Fedora does have a shutdown button, but it is hidden in a very stupid way. To get to the shutdown button, you have to hold down the ALT key as you look at the menu where you found the Log Out option. This is not your fault, but a terrible idea that somebody should have realised by now!


This surely has to be as stupid and irritating as the hidden Windows 8 shutdown option. However, I think we have to accept that operating systems these days are increasingly being designed for mobile touchscreen devices (always on or sleeping) and users of conventional desktop computers (of which I am most definitely one) are simply expected to like it or lump it. Hey-ho. Confused

(I haven't tried Fedora recently so was unaware of this, but if I had run into this problem I think I would just have resorted to shutdown -h now in the terminal. Life's too short to spend hours googling trying to find solutions to problems which shouldn't be there in the first place.)
Back to top
View user's profile Send private message
Old_Timer



Joined: Sun Jul 15, 2012 9:32 pm
Posts: 3
Location: near Evesham

PostPosted: Tue Jul 17, 2012 5:53 pm    Post subject: Fedora 17 Live Disk caused a PC to Re-Boot on Shutdown Reply with quote

I am very sorry but I now remember that I missed out certain points on my original report, due to my very poor short-term memory. I have been thinking a little more about the actual process I used when the process went wrong. Most of the time for the Live Disk use of Linux Format dvd's I use a bent paper-clip as a pointer and put that into the DVD release-hole to get the drawer out and then put the required DVD in before powering up the PC. Obviously that then enables me to boot from DVD normally. Also, thinking more about the problem occurance, I now recall that [b]after [/b]having discovered the problem I found that when typing a Notepad file [for memory purposes] I discovered that the Keyboard was not correctly setup and was typing incorrect characters. So I used Google and I found that the default setup for Fedora 17 keyboard is set to the USA version of keyboard. So I wonder if the combination of the original problem of Clicking the "LOG-on/off" button, combined with the US keyboard may have caused the problem. Whatever it is (and it is still on now) must be connected. I used the live DVD setup and programs to play Sudoku and access the Internet for a couple of hours or so with no problems at all. The trouble only started after clicking the "Turn Off Computer Buttons, albeit with an American Code talking tthrough my keyboard? Does that issue ring any bells?

Many thanks for your valuable help, it is much appreciated
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast