Mythtv 5.1 sound from TV [SOLVED]

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Mythtv 5.1 sound from TV [SOLVED]

Postby wyliecoyoteuk » Fri Jun 15, 2012 7:58 am

Just invested in an Onkyo surround sound system.
(was surprised when it arrived, IT'S HUGE!- actually much bigger than my Media PC, wife not amused...)
However, I am running Mythbuntu 12.04, but cannot get a squeak from the rear speakers when watching TV or recordings, whereas DVDs or Music are fine.
Any ideas where to start looking?

Nvidia on board sound chip (MSI media live PC), Hauppuage WinTV Nova-T 500
Last edited by wyliecoyoteuk on Sat Jun 16, 2012 9:26 am, edited 2 times in total.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby bobthebob1234 » Fri Jun 15, 2012 9:29 am

Probably something to do with 5.1/7.1 surround sound.

What connections are there between the Onkyo and mythtv box?

When I connect my mythtv box to a surround sound(ss) box I have "true" ss go though optical cable, and that is for dvds, then cos tv is just plain old stereo goes though plain old stereo cables.

Whether mythtv has a way of converting stereo to 5.1 surround sound I don't know, but my sound system has a magic button to make everything surround sound
For certain you have to be lost to find the places that can't be found. Elseways, everyone would know where it was
User avatar
bobthebob1234
LXF regular
 
Posts: 1373
Joined: Thu Jan 03, 2008 9:38 pm
Location: A hole in a field

Postby wyliecoyoteuk » Fri Jun 15, 2012 10:20 am

At the moment, I am feeding it all through 6 coax leads until I can get the required HDMI or optical cables.
(The Onkyo forwards HDMI sources).
I thought that MythTV would upscale the audio, and I think that it is set to, but I only get sound out of the front-Left, Right, middle and the Subwoofer. Unless I am playing music-mp3 or ogg, etc. , when it all works fine.
I'll have to read the (quite thick) Onkyo manual, I suppose.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby bobthebob1234 » Fri Jun 15, 2012 10:28 am

Its a little weird that you are getting thought left, right AND middle. I would have thought stereo would just be left and right. Maybe the Onkyo is doing something a little weird

Have you explicitly told Myth to upscale the audio? Mine didn't do it automagically. Maybe it is only upscaling music but not tv. All a bit strange...
For certain you have to be lost to find the places that can't be found. Elseways, everyone would know where it was
User avatar
bobthebob1234
LXF regular
 
Posts: 1373
Joined: Thu Jan 03, 2008 9:38 pm
Location: A hole in a field

Postby wyliecoyoteuk » Fri Jun 15, 2012 11:00 am

Don't think it is the Onkyo, had the same issue with my previous (V. old)Creative unit, but that was a fairly simple SubAMP based one, so I didn't worry about it.
Yes, it is upscaling music, and possibly video sound (not tried that yet), but not TV.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby wyliecoyoteuk » Fri Jun 15, 2012 4:26 pm

Doh!
Just looked at the manuals again.
I assumed that the speakers were front and rear with the surround being the 7.1 pair.
In fact they are labelled front and surround, the rear are for 7.1 only.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby wyliecoyoteuk » Sat Jun 16, 2012 9:26 am

NO, I was wrong, the surround speakers just won't do TV from Myth, but I did find the magic button (Stereo all chann) on the Onkyo, so now it all works OK :)

I also got some HDMI leads, so I can ditch the Coax.
Surprisingly easy to get the HDMI audio working, read some nightmare stories. I just had to select in the MythTv setup.
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK

Postby wyliecoyoteuk » Tue Jun 19, 2012 4:42 pm

Now I have another problem.
I can output digital audio from the PC to the receiver, but I also need analogue audio for my kitchen and dining room wireless speaker system.
The receiver won't transcode digital to analogue for line outputs.
Can I get the output from MythMusic to analogue and digital simultaneously somehow?
I have got a USB soundcard, would that work?
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
User avatar
wyliecoyoteuk
LXF regular
 
Posts: 3465
Joined: Sun Apr 10, 2005 10:41 pm
Location: Birmingham, UK


Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests